Frissítés MySQL 8-ra

2021 júliusától csak a MySQL 8.0 lesz elérhető a webtárhely-adatbázisok számára. A régebbi verziókat már nem használjuk.

A jelenlegi szoftverek kompatibilisek a MySQL 8-cal, csak az elavult szoftverek vagy saját fejlesztésű rendszerek esetében lehetnek kompatibilitási problémák:

  • Új kulcsszavak kerülnek bevezetésre a MySQL 8-ban. Ha a táblázatok vagy oszlopok neve ilyen kulcsszavakhoz hasonlóan van megadva, akkor az SQL-lekérdezésekben ezeket a kulcsszavakat hátulról kell beírni (pl. `groups` helyett groups), vagy az oszlopot át kell nevezni. Kulcsszavak a MySQL 8-ban
  • a PASSWORD() funkció már nem elérhető
  • az SQL módot mi nem változtatjuk meg

A következő szoftververziók kompatibilitásához legalább a következő verziók frissítése szükséges. Nincs tudomásunk más szoftverek kompatibilitási problémáiról.


Szoftver min. Verzió
Concrete 5 8.4.1
Contao 3.5.40
Drupal 8.6.x
Shopware 5.5