Future support for WSC 5.2

The End of Life

As is actually the case with every new WSC version, this also brings closer the so-called EOL (End of Life) of our

Plugins for older versions is getting closer. I handle it relatively simple. Supported is the current version,

as well as the previous version. So the support for the WSC 5.2 will be already some weeks or even

only days after the release of WoltLab Suite™ 5.4 from our side is no longer offered. More information will be available when the time comes. There will be some kind of "transition period", of course.

So there will be a maintenance update released for each product, which will exclude WSC <5.2.


Clearly there are certainly reasons not to use the very latest version, hence the option on our part,

to continue to use the 5.3. Until the 5.5 there will probably be support and updates. ;)


Compatibility & small look into the future.

As I have seen so far, it is not necessary that we have to change our plugins or styles widely to make compatibility. On my schedule at the moment is the redesign of the Grayer, Autumn, Summer & Winter styles.

But it is not required for 5.4, as no "major" changes have been announced there.

A new style called "Spring" I postpone to next year, spring is already gone now. X/

In terms of plugins, the implementation of the FormBuilder into the "copy plugins" is pending, though I need to get busy on that.

The profile fields don't need a compatibility update for now. However, the redesign may drag on a bit as there is quite a bit going on at work, and I am now also going to driving school.


Package server

The package server for the 5.2 will remain, I will not disable the downloads for the 5.2 for now either.

Only, there will be no more help or updates.

For the PlugIn store, there is now the package server at the URL: https://d1strict.de/packages/5.4/stable/

and for the store: https://d1strict.de/shop/update/3-5-4/.